Intro Scilab

Envoyer Imprimer PDF

Scilab

Dans les version récentes de linux, un paquet scilab est disponible. Sinon les sources précompilées sont téléchargeables sur le site officiel : lien.

Pour installer scilab à partir des sources :

  • télécharger le code source à partir du site officiel : lien.
  • détarrer :
tar zxvf scilab--src.tar.gz
Tout d'abord il faut lire le README du dossier décompressé. Il y est listé les versions de linux sur lesquelles l'installation a été testée et les besoins dans les options du ./configure (tcl, pvm, tk, …).
  • tapez les commandes suivantes :
$ cd scilab-
$ ./configure --without-pvm --prefix=/ --with-shared
$ make all
$ make install
  • L'option '- -without-pvm' sert à installer scilab sans les librairies de calcul parallèle.
  • L'option '- -prefix' permet de choisir le repertoire d'installation des binaires (pas nécessaire si on veut l'installer dans le répertoire par défaut).
  • L'option '- -without-java' ou '- -without-javasci' permet de configurer pour que scilab n'utilise pas java.


Pour utiliser les librairies lors des interfaçages Scilab-C : ne pas executer la commande make install donc pas besoin de l'option –prefix=/chemin
L'exécutable scilab se trouvera dans le repertoire /bin/

Scilab v5.x est tout nouveau… il utilise notamment les fonctionnalités :

  • libmatio : librairie pour ecrire en .MAT (option '- -without-matio' disponible)
  • flexdock : utilisé pour la GUI (interface graphique)

hardy (v8.4)

Le problème est que libmatio et flexdock ne sont pas disponibles dans les paquets, donc mieux vaut mettre les versions 4.x sauf si vous êtes très bricoleurs…

          Pour ce qui regarde flexdock: aller sur http://www.scilab.org/download/index_download.php?page=5.1.1 et
sous "Prerequirements to compile Scilab 5.1.1" cliquez sur le lien approprie: "32 bits version" ou "64 bits version"
selon votre systeme. Une fois l'archive telecharger et decompressee, copier dans votre repertoire /usr/share/java
(sous sudo) tous les fichiers .jar du repertoire /thirdparty/ de l'archive nouvellement telechargee et decompressee.
La compilation ne devrait plus posser de probleme pour le point "flexdock".

interpid (v8.10)

Les paquets sont disponibles, à vous d'essayer.

Mise à jour le Samedi, 06 Février 2010 11:58